Back to overview
Downtime
Server down
Nov 09 at 09:56am CET
Affected services
Block-Lands
API
Resolved
Nov 09 at 10:04am CET
Server's back up
Affected services
Block-Lands
API
Created
Nov 09 at 09:56am CET
Server is temporarily down
Affected services
Block-Lands
API